Kernel 4.4 LTS

I decided to give kernel 4.4 a try and downloaded + installed it like this:

$ wget \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400_4.4.0-040400.201601101930_all.deb \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400-generic_4.4.0-040400.201601101930_amd64.deb \
kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-image-4.4.0-040400-generic_4.4.0-040400.201601101930_amd64.deb

$ sudo dpkg -i linux-headers-4.4*.deb linux-image-4.4*.deb

After restart I got the “ALERT! /dev/disk/by-uuid/xxxxxxxxx does not exist” and was dropped to a shell. I rebooted with a 3.x kernel and after some googling I found that someone with a XPS15 (9550) resolved the same problem by adding the line “nvme” to /etc/initramfs-tools/modules and running update-initramfs -u. This turned out to work to for me as well so after a reboot with only the default kernel params (quiet splash) I could get all the way to the desktop.

Notes from running the 4.4 kernel:

  • Suspend works

This is great. Didn’t try if returning from locked screen works as well though.

  • Virtual Box stopped working

This is a blocker since I depend on Vagrant + VirtualBox for all my development. Seems to be related to dkms.

  • Graphical artifacts

Some kind of graphical artifacts appear, probably related to incompatible video driver.

  • Lower power consumption

For the first time ever since I started using powertop, I can see sub-10W values (9.x W).

All in all, the negative aspects are bad  enough to uninstall the 4.4 kernel and go back to the 3.x kernel :(